Voor uitgaand verkeer van Telavox
Maak een regel aan voor alle UDP- en TCP-poorten voor het Telavox-netwerk 80.83.208.0/20.
Voor deze regel is een UDP- en TCP-time-out van minimaal 3720 seconden vereist, aangezien onze telefoons elke 3600 seconden contact met ons opnemen. Als u de time-out niet kunt verhogen, neem dan contact op met onze supportafdeling. Wij kunnen het registratie-interval voor het toestel verlagen naar 240 seconden.
Informatie
Afhankelijk van de fabrikant van uw firewall kan de naam van deze parameter verschillen.
Hieronder vindt u enkele voorbeelden:
FortiGate: Sessie TTL
Cisco ASA: time-out UDP/TCP
Palo Alto Networks: Applicatietime-outs
SonicWall: UDP/TCP-verbindingstime-out
MikroTik: Time-out voor het volgen van verbindingen
Juniper SRX: Sessietime-out UDP/TCP
WatchGuard: UDP/TCP-time-out
pfSense: Time-outwaarden voor de status
Voor inkomend verkeer naar Telavox
Hier zijn geen regels nodig, aangezien de sessie vanuit het netwerk zelf wordt geïnitieerd. Schakel alle ALG/SIP-functies en applicatiebeheer voor verkeer naar Telavox uit, indien dit in de firewall is ingeschakeld. Deze functies doen meestal meer kwaad dan goed.
Volledige informatie over ons netwerk:
Address : 80.83.208.0
Netmask : 255.255.240.0 = 20
Wildcard : 0.0.15.255
Network : 80.83.208.0/20
Broadcast : 80.83.223.255
HostMin : 80.83.208.1
HostMax : 80.83.223.254
Hosts / Netwerk : 4094
Terminals en bevoorrading:
De volgende IP-adressen en netwerkbereiken moeten beschikbaar zijn om automatische provisioning te laten werken.
Gigaset redirect server
Hostnaam: secure-provisioning.gigaset.net Poort : 443
Yealink redirect server
Hostname: rpscloud.yealink.com Poort: 443
More info
Snom redirect server
IP-adres: 52.28.89.237 Poort: 80, 443
Grandstream redirect-server
IP-adres: 52.221.130.73 Poort: 443
Fanvil redirect server
IP-adres: 119.28.67.228 Poort: 80, 443
Poly redirect server
Hostnaam: ztp.polycom.com Poort: 443
Meer informatie
Akuvox redirect server
Hostname: redirect.akuvox.com Poort: 80, 443, 8080
Telavox Provisioning Server:
Gigaset: 80.83.208.0/20 Poort: 80
Gigaset IP PRO : 80.83.208.0/20 Poort : 1449
Yealink: 80.83.208.0/20 Poort: 442
Snom: 80.83.208.0/20 Poort : 447
Grandstream: 80.83.208.0/20 Poort : 443
Fanvil: 80.83.208.0/20 Poort : 443
Poly: 80.83.208.0/20 Poort: 443
Akuvox: 80.83.208.0/20 Poort: 443
Protocol
Hieronder staan de protocollen die worden gebruikt door apparatuur van Telavox, samen met een beschrijving van hun functie. Verschillende terminaltypen gebruiken verschillende protocollen.
Telavox raadt af om verkeer van en naar terminals te blokkeren op basis van poorten en/of protocollen, maar vertrouwt er in plaats daarvan op dat al het verkeer van en naar het Telavox-netwerk wordt doorgelaten. Telavox verbindt zich er ook niet toe om voor altijd alleen de onderstaande protocollen te gebruiken. Het beperken van toegestaan verkeer via firewalls op basis van de onderstaande protocollen kan daarom gevolgen hebben voor de geleverde diensten als de onderstaande specificaties wijzigen. Houd er rekening mee dat de in alle gevallen vermelde poorten ontvangstpoorten zijn; de apparatuur gebruikt doorgaans willekeurig geselecteerde verzendpoorten.
HTTPS
Hypertext Transfer Protocol over Secure Socket Layer, RFC2818, TCP-poort 443. Wordt gebruikt om terminalconfiguratie en software op te halen.
SNTP/NTP
Simple Network Time Protocol, RFC1305/RFC1361, UDP-poort 123. Wordt gebruikt om de tijd/klok in de terminal in te stellen.
SIP
Session Initiation Protocol (SIP), RFC3261, UDP-poort 5060. Wordt gebruikt voor het tot stand brengen van inkomende en uitgaande gesprekken. SIP-verkeer verloopt tussen onze SIP-server en de telefoon. Dit is verreweg het belangrijkste protocol voor een goed werkende telefonie.
SIP-TLS (Secure SIP)
Session Initiation Protocol over Transport Layer Security, RFC 3261, TCP 5061. SIP over TLS wordt gebruikt voor versleutelde SIP-signalering. Dit betekent dat SIP-berichten via TLS (Transport Layer Security) worden verzonden. Dit is veiliger dan de reguliere SIP-poort 5060, die UDP/TCP zonder versleuteling gebruikt.
RTP
Real Time-Transfer Protocol (RTP), RFC1889, UDP-poort 1024-65535. De audiostream tussen de terminal en de telefoon tijdens een gesprek verloopt via RTP. Welke poort wordt gebruikt, wordt willekeurig geselecteerd wanneer een gesprek wordt gestart. Alle door Telavox geleverde terminals gebruiken symmetrische RTP, wat betekent dat de ontvangende en verzendende poort voor de RTP-stream hetzelfde is voor zowel inkomende als uitgaande audiostreamen. Dit betekent dat de audiostream die van de terminal naar ons gaat, de sessie in de firewall opent om ook inkomende spraakstreamen via dezelfde sessie toe te staan.
SRTP
Secure Real-Time Transfer Protocol. De gegevens worden nog steeds via UDP verzonden, maar beide partijen in het gesprek hebben sleutels uitgewisseld bij het opzetten van het gesprek in de SIP-dialoog om encryptie mogelijk te maken.
RTCP
Real Time Control Protocol (RTCP), RFC3550, UDP-poort 1024-65535. Sommige terminals genereren RTCP-pakketten die worden gebruikt voor communicatie tussen RTP-eindpunten om lokale statistieken en gespreksgegevens over te brengen, zoals informatie over jitter en mogelijk pakketverlies. Deze poort wordt gekozen als RTP-poort + 1, d.w.z. als de RTP-stream via poort 12480 loopt, gebruikt RTCP UDP-poort 12481.
WSS WebSocket
WSS wordt gebruikt door onze softphone "Telavox desktop" en gebruikt poort 8443 voor "pushservers" en poort 443 voor SIP.